DS Linux toolchain: unable to compile custom configuration

Stefan Sperling stsp at stsp.name
Mon Jul 4 12:16:34 CEST 2011

On Sat, Jul 02, 2011 at 05:29:37AM +0200, Mark Ngbapai wrote:
> I've set up the toolchains and exec "make menuconfig"and I'm able to
> compile DSlinux with all defaults. Of course all useful programs and
> libraries are missing and the resulting ROM is merely 1,7 MB in size.
> I tried then to compile with libnet and ncurses among other libraries
> but "make" exits unexpectedly.

> make[4]: *** ../../.config: Is a directory.  Stop.

> It seems to me that the problem is related to : "make -C extra/config
> conf" but I can't figure out what is missing. What could I been doing
> wrong? Thanks in advance.

I ran a bulkbuild recently (see bulkbuild.sh).

There was some fallout during the build, but it was different from
yours. But all errors I got had a common pattern: The timestamps on
files happened to be set such that Makefile rules regenerated some
files that should not be regenerated. The regenerated files then
differed in a way that made the build fail (I had quite a few 'config.h'
files being regenerated causing build failures).

This was after a clean svn checkout. The timestamps depend on the
order in which svn creates files on disk.

I suspect that you're running into a similar issue.
Try to figure out where this 'config' directory is generated.
Maybe it is generated by some rule that is run because timestamps
on some files are the reverse of what they would be for a good build.

Ideally we'd hack all Makefiles in the tree to never recreate such
files. This isn't trivial because we're using a lot of Makefiles
from upstream projects, and they all differ in subtle ways.
And we're running stuff like configure scripts which might decide
to regenerate files, too.

You can run 'svn diff' to see which files are changed by the build.
Any change that shows up out of the blue after you've run a build
is a potential reason for build failure.

But I did manage to get all builds to compile.
I'll see about committing the local changes I have in case it helps.

More information about the dslinux-devel mailing list