Toolchain doesn't compile with GCC 4.3

Stefan Sperling stsp at
Mon Jul 21 14:40:34 CEST 2008

On Mon, Jul 21, 2008 at 01:19:47PM +0100, Benjamin Lewis wrote:
> Just though I'd let you all know: the toolchain won't compile with GCC 
> 4.3. This dosn't really matter, of course as I can just use the 
> precompiled version, I was just curious to see if it did or not.
> Should I make a note on the wiki about this like the one we have for 
> AMD64 users?


But in the long term, the toolchain components will need to be
updated to newer versions anyway. A newer binutils version might
fix the problem you're seeing.

I've tried rebasing the toolchain to gcc-4.2 once. It compiled,
but only produced panicing kernels for reasons beyond me. I tried
to debug it, but failed. There are patches that patch newer gcc
versions with the 8bit write support we need. They are in the
toolchain/patches/ directory. The toolchain currently still uses
gcc-4.0.2, I left the patches for newer gcc versions in place though
for anyone who wants to tackle this again.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url : 

More information about the dslinux-devel mailing list