Cause of the C++ problem

Troy Davis gpf at
Mon Jul 30 23:51:52 CEST 2007

Quoting Amadeus <amadeus at>:

> Hello everybody,
> On Freitag, 20. Juli 2007, Amadeus wrote:
> > I digged somewhat deeper into the problem
> ... and finally I fixed it.
> I have looked at other architectures how they do it, and found another
> working solution from the blackfin team. It had to be modified for ARM,
> but it works!
> So it is possible now to use virtual functions in C++ programs.
> Every developer need a new toolchain.
> For reference, I have uploaded my toolchain to
> Kineox, are you listening?
> regards
> Amadeus
> --
> We're back to the times when men were men
> and wrote their own device drivers.
> (Linus Torvalds)
> --
> dslinux-devel mailing list
> dslinux-devel at

Awesine work, just downloaded your toolchain, ran make distclean and rebuilt
everything and rtest work great :)

I tried to port a c++ program that uses my in progress libSDL and zlib, and I am
getting the following error when linking

 -xsh- ~/dslinux/user/REminiscence > make
make[2]: Entering directory `/home/gpf/dslinux/user/REminiscence'
ucfront-g++ arm-linux-elf-g++  -Wl,-elf2flt -D__PIC__ -fpic -msingle-pic-base -
swp-byte-writes -o rs collision.o cutscene.o file.o game.o graphics.o main.o me
u.o mixer.o mod_player.o piege.o resource.o scaler.o sfx_player.o staticres.o s
stemstub_sdl.o unpack.o util.o video.o -lSDL -lz -luClibc++
rs.elf2flt:(.gnu.linkonce.d._ZTI8zlibFile[typeinfo for zlibFile]+0x0): undefine
 reference to `vtable for __cxxabiv1::__si_class_type_info'
rs.elf2flt:(.gnu.linkonce.d._ZTI9File_impl[typeinfo for File_impl]+0x0): undefi
ed reference to `vtable for __cxxabiv1::__class_type_info'
rs.elf2flt:(.gnu.linkonce.d._ZTI7stdFile[typeinfo for stdFile]+0x0): undefined
eference to `vtable for __cxxabiv1::__si_class_type_info'
rs.elf2flt:(.gnu.linkonce.d._ZTI14SystemStub_SDL[typeinfo for SystemStub_SDL]+0
0): undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
rs.elf2flt:(.gnu.linkonce.d._ZTI10SystemStub[typeinfo for SystemStub]+0x0): und
fined reference to `vtable for __cxxabiv1::__class_type_info'
collect2: ld returned 1 exit status
make[2]: *** [rs] Error 1
make[2]: Leaving directory `/home/gpf/dslinux/user/REminiscence'

Any ideas?


More information about the dslinux-devel mailing list